1 install.inc protected DatabaseTasks::checkEngineVersion()

Check the engine version.

File

core/includes/install.inc, line 555
API functions for installing modules and themes.

Class

DatabaseTasks
Database installer structure.

Code

protected function checkEngineVersion() {
  if ($this->minimumVersion() && version_compare(Database::getConnection()->version(), $this->minimumVersion(), '<')) {
    $this->fail(st("The database version %version is less than the minimum required version %minimum_version.", array('%version' => Database::getConnection()->version(), '%minimum_version' => $this->minimumVersion())));
  }
}